VOG Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
290 Posts
Discussion Starter · #1 ·
I bought my 08 Hammer new at the beginning of April this year. About 2 months after I had the new slashness pipes, and the stage 1 air kit installed. Things I notice before, nad after the upgrade.
While stock I noticed it popped, although the stock mufflers kept it quiet unless you were listening for it. What I didn't like was the fact that the bike stalled when trying to accelerate from a stop. If I blipped the throttle while slowing down it would stall sometimes too. I mentioned this to the dealer, and they said I was riding my bike wrong.
Then I install the new pipes with the new mapping update. The stalling issue was still there. Now ontop of that my bike would pop, and gurgle when idling. When I start it from cold it would run fine, but as the bike warmed up the popping, and gurgling would increase until it was fully warmed up, then it was constant. I complained to the dealer a lot about this.I brought it in, and they would say that it was normal. They would adjust the throttle freeplay, and call it a day. Once they said they hooked it up to the computer to record what it was doing, and was going to forward it to Victory fo analysis. I never heard back from them on it, so I just accepted it, considering all the stuff I've been reading on forums with the 08's and up. Well last week I met a guy who owned a 08 Hammer with Victory swept pipes on his bike, and he didn't have any popping at idle or stalling issues.
So this last Saturday I rode to my dealer 30km+ because I wanted them to hear my bike idling. They have a new service guy there now, and he took my bike for a ride, and listened to it idle, and he told me something wasn't right. The mechanic took it into the shop, and a half hour later came, and told me the intake manifold had seperated (what ever that means, I can't visualize it), and that he had a new one. He said it would take him approx. 1-1/2 hours to replace so I agreed to wait.
BINGO it now idles fine, and runs a whole lot better. I mean it still pops a little at idle but no where near as it use to. It hasn't stalled, but then again it stalled once in a while anyway. So if anyone has the symptems I have get the intake manifold checked out. I always though it was lean at idle, and I was right, it was leaking from the manifold.
 

·
Registered
Joined
·
657 Posts
Thanks for the information. I'm glad the problem has been solved. It is unfortunate but sometimes the way to get service is to be a pest, a pain the the behind, for the service department. Shouldn't be that way but is often the only solution.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top