VOG Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
101 Posts
Discussion Starter · #1 ·
OK, I've got an 05 Kingpin with Stage 1 Vic exhaust, K&N and was told it was remapped when it was purchased with the stage 1 kit. I keep reading how people are getting 40-50 mpg, I'm typically getting around 35 (light is always on before 140 miles) and get gassed out when I stop at a stop light. I've even had people tell me they can smell the gas when following me and I get on it.
Stopped at local Vic shop today and asked about it. Says he can hook up to laptop and check mapping but thought it may also be a fuel pump with low pressure. Has anyone else heard of this causing bike to run rich? Also suggest to change plugs annually since at start up EFI is programmed to run rich for first minute and can foul plugs if you do lots of start and stop driving. This will be my first attempt (any plug recommendations?).
Has anyone ever tested their own fuel pump pressure, what is needed to do it?

Any help is appreciated, just bought the bike this spring and love it but I don't want to spend a bunch more money since the economy sucks and I keep dumping money into my delinquent Dodge truck.
Thanks
Brian
 

·
Registered
Joined
·
11,722 Posts
That is interesting. Most run lean. I would pull the plugs and get a look at them. If the pump is not pushing well you get less gas not more

How many miles on it? Throttle body cleaning maybe.

Hard to tell really unless he checks your map to make sure its right.

My 06 gets a fuel light at 135 miles so don't feel all alone.
 

·
Registered
Joined
·
66 Posts

I bought an 07 Kingping Tour in April (zero miles) w/stage I Drags and have only once attained over 40 mpg - usually around 38 even after 4500 miles. My plugs are constantly carboned up so I went to the Platinum and they worked well for 1k miles. They too run very rich. It has begun to misfire. I am concerned the gap may not be properly adjusted. I was told not to change the gap as I will removethe platinum off the plug which is why they come pre-gapped. I have changed the plugs 4 times. I have a buddy with the same bike and he commonly gets over 40 and is not getting the same problem (although his pipes do soot up some as well).
Could it be our bikes were not MAP'd correctly? I had them look at it at 500 miles and they said it was good. Can it change?
You may want to look at your plug wires as I know some who have had theirs "pop" off the end of the plug.
I am thinking we may have a common issue.
 

·
Registered
Joined
·
101 Posts
Discussion Starter · #4 ·
Bikes got a little over 4000 miles on it...don't blame me I bought it this spring with 1600, previous owner just never rode much.
I've checked and cleaned the plugs once but can't remember the condition. May have to order a set of the latest snake oil plugs (E3 or Halo) and see how those perform.
I also was a little confused on the tech's explanation of how a weak fuel pump could make it run rich. Unless the injectors just get confused with the lower pressure and don't get as good of a spray making it rich ?
It's getting close to the end of the riding season here, maybe a good month and half left, I'll probably change plugs soon and check everything over good during the winter.

On a side note, just looked at the bottom of the page as I was typing. Kind of odd to see a Harley add on the Vic site.
 

·
Registered
Joined
·
4,500 Posts

05 I think is 92 inch and I think you have a 5 speed (could be wrong).A ton has to do with the way you ride. 1 or 2 up, ride at higher RPM's before shifting, city driving. I don't think you are that far off on MPG based on what you have. All Vic's run rich, especially at start up. When you start the bike, do you let it warm up for a short while, do you use the fast idle? If not, trythis. Even if the are hot, they still go through a rich cycle when you first start it. If someone is behind you and you take off without a warm up, they could small gas.
If you are really stuck on getting better gas milage, you can get a front sprocket that a tad larger. Gas milage should go up because the RPM's are lower.
 

·
Registered
Joined
·
917 Posts
Sunbum said:
I bought an 07 Kingping Tour in April (zero miles) w/stage I Drags and have only once attained over 40 mpg - usually around 38 even after 4500 miles. My plugs are constantly carboned up so I went to the Platinum and they worked well for 1k miles. They too run very rich. It has begun to misfire. I am concerned the gap may not be properly adjusted. I was told not to change the gap as I will removethe platinum off the plug which is why they come pre-gapped. I have changed the plugs 4 times. I have a buddy with the same bike and he commonly gets over 40 and is not getting the same problem (although his pipes do soot up some as well).
Could it be our bikes were not MAP'd correctly? I had them look at it at 500 miles and they said it was good. Can it change?
You may want to look at your plug wires as I know some who have had theirs "pop" off the end of the plug.
I am thinking we may have a common issue.
I think you can check the plug gap with a feeler gauge without scraping anything off to at least rule out incorrect gap. My 07 KPT rarely gets over 40 mpg unless I ride at 55mph. I've had mine leaned out because of excess soot on the fender and what I thought was poor mileage. I've come to realize it runs way better when it's a tad rich. For example the first 5min. after cold start is the smoothest running time for my bike. Leads me to believe my bike is running too lean. Incidently, I had to have my throttle position sensor replaced a couple months back.
 

·
Registered
Joined
·
6 Posts
Sunbum said:
I bought an 07 Kingping Tour in April (zero miles) w/stage I Drags and have only once attained over 40 mpg - usually around 38 even after 4500 miles. My plugs are constantly carboned up so I went to the Platinum and they worked well for 1k miles. They too run very rich. It has begun to misfire. I am concerned the gap may not be properly adjusted. I was told not to change the gap as I will removethe platinum off the plug which is why they come pre-gapped. I have changed the plugs 4 times. I have a buddy with the same bike and he commonly gets over 40 and is not getting the same problem (although his pipes do soot up some as well).
Could it be our bikes were not MAP'd correctly? I had them look at it at 500 miles and they said it was good. Can it change?
You may want to look at your plug wires as I know some who have had theirs "pop" off the end of the plug.
I am thinking we may have a common issue.
 

·
Registered
Joined
·
6 Posts

I HAVE SOME MINOR POPPING,BUT THIS IS USUALLY INVOLVED WITH A DECELL ON THE THROTTLE"CLOSED POSITION" AND ADDING TO MUCH GAS IN THIS POSITION,,I HAVE FOUND THAT THE VICS LIKE TO RUN RICH AND WITH MY STAGE ONE INSTALL IT WAS MAPPED WITH THE STANDARD STAGE 1 "SLIP ON PIPE'" MAPP,THIS MAPP IS NOT TO AGGRESSIVE AND SEEMS TO RUN OVERALL QUITE GOOD,,I DO GET A LITTLE SOOT ON THE BACK FENDER BUT THIS IS FROM A RICH CONDITION FROM THE MAPP.I GET AROUND 36.5 TO 38 IN CITY DRIVEING,BUT WHEN OUT ON THE ROAD IN 6TH GEAR I WILL PUSH TO 42 TO 46,HAVE GOTTEN 52,BUT THAT WAS COMMING DOWN A PASS WITH VERY LITTLE DEMAND ON THE ENGINE..
NOTE TO SUNBUM:I WILL DRIVE UP AND BRING YOU A BREW AND TAPE YOUR SPEED RACER WRIST IN A FLAT POSITION ON YOUR THROTTLE!!!
 

·
Registered
Joined
·
101 Posts
Discussion Starter · #10 ·
Main goal wasn't to get better milage, though it would be nice, it was the ever present smell of gas cold or hot when you come to a stoplight. I'll try new plugs and see what happens.
 

·
Registered
Joined
·
6 Posts
kingpin05//just a heads up,i had a strong smell of gas at stoplights and it turned out to be a loose gas hose on the right side of the gas tank,,behing the cheese wedge,it was so bad that ti could see it drip slowly down on the case,,take a look and it can be tight with a standard flat scewdriver,,this was the case on my 07' kingpin////good luck fernpicker
 

·
Registered
Joined
·
66 Posts
FERNPICKER said:
NOTE TO SUNBUM:I WILL DRIVE UP AND BRING YOU A BREW AND TAPE YOUR SPEED RACER WRIST IN A FLAT POSITION ON YOUR THROTTLE!!!
Well, I'm waiting for that brew! You can help me lube my throttle body as well. You still leaving tomorrow?
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top