VOG Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
So I pickup my new Mignight Cherry Cross Country today and was driving around, and the engine light and the battery light come on. The charge indicator also swings to the top.
I pull over and the lights and gaude return to normal. I do a quick check and all looks good. I continue driving and it happens again, but this time they return to normal on thier own. First the gauge and then the lights. This happens a few more times before it goes away for a longer time.
Stop for a bit (2 Hours)then head back out. And first the gaude goes up the lights go on, the gauge goes down and lights go off. a repeat of what happen earlier.
The lights only stay on for about 5 minutes before everything returns to normal.
When I got home, I check the battery connections and they are tight.
Read the manual and will now check for codes.
Any hints before I ride back to the dealer and get them to look for something that I can not reproduce on demand?
 

·
Registered
Joined
·
1,366 Posts
Take it back to the dealer...it's brand new!
 

·
Registered
Joined
·
239 Posts

I thought my electronics were faulty since the trip computer would change by itself.
Then I realized that I had adjusted the clutch...well I adjusted it so that the clutch lever hits the trip computer button. Just more proof that I am dangerous with tools.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #8 ·

Took it to the dealer today. They figure it might be the regulator. So I left it with them to check things out. I was also at 870 KM, so they performed first service.
When I picked up, they said they tested everything and found no issues. They cleaned up the ground connections and reconnected connectors. Nothing wrong.
So, they want me to ride around and try and get a better feel to when it occurs.
Beinginvolved in the computer industry I can understand how hard it is to find a fault when all the componets are working.
On a side mote. High praise to the dealership. I was not expecting to leave my bike for the day, so they lent me a Vision for me use. They were perpared to let me have the Vision for the night if my bike was not ready. Good customer service!
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top