VOG Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
85 Posts
Discussion Starter · #1 ·
So when I pull out from anywhere and really wind out a couple of gears my bike for the rest of the ride, for any amount of miles, runs HORRIBLY. I don't know much about Fuel Injections, but to describe it, if it were a carb bike, it runs like there is trash in the fuel, or its missing.... now here is the weird part >>> while it is running rough, if I kill the engine by either stopping or a quick off and on while running down the road, it runs a LOT better????

Just a guess, but I am thinking when I turn it off it resets the EFI. At any rate - I don't like it. My bike has a stage one kit and 5000 miles on it. Would installing a Power Commander remedy any fuel/air mix problems? Thanks -sa
 

·
Registered
Joined
·
4,500 Posts
Did you ever clean the throttle bodies? Sounds likethey are dirty
 

·
Registered
Joined
·
85 Posts
Discussion Starter · #4 ·
Nope - never cleaned them. I don't understand how a quick on and off of the kill switch while cruising down the road fixes the "rough running" if the throttle bodies are simply dirty. Strange -sa
 

·
Registered
Joined
·
6,128 Posts
It won't. I think you have something more going on...but I'll leave that to the pros.
 

·
Registered
Joined
·
46 Posts
I will bing this back up also I have the same thing with my bike 04 kingpin run real good then when I grab a handfull slow down it acts like I am starving for fuel tryed the reset thig alot of times that works tell I grab a handfull
 

·
Registered
Joined
·
85 Posts
Discussion Starter · #11 ·
I don't even have to really get on it now... seems like a increase 200-300 rpms in any gear makes it start acting like its running out of fuel or missing.?.?.

If I get on it hard, its obvious and instant.

I have to hit the on/off switch while in motion real quick and it go back normal full running power... till I speed up a little.

Beyond stock 05 V92, the only thing I think that has been done are the addition of the RPG? Slash down pipes... Vic Mechanic said it "looked" like I had Stage 1 Kit when he helped me adjust spring (unrelated before I knew about the problem).

It SEEMS LIKE my pipes are Bluing awfully fast up top - I don't know if that is related - just an observation.
 

·
Registered
Joined
·
637 Posts
I don't even have to really get on it now... seems like a increase 200-300 rpms in any gear makes it start acting like its running out of fuel or missing.?.?.

If I get on it hard, its obvious and instant.

I have to hit the on/off switch while in motion real quick and it go back normal full running power... till I speed up a little.

Beyond stock 05 V92, the only thing I think that has been done are the addition of the RPG? Slash down pipes... Vic Mechanic said it "looked" like I had Stage 1 Kit when he helped me adjust spring (unrelated before I knew about the problem).

It SEEMS LIKE my pipes are Bluing awfully fast up top - I don't know if that is related - just an observation.
If you still have stock pipes with the cats in could be restricted. That will choke on higher rpm and progressively get worse. The head pipes will glow at night when it gets really bad. Running too lean is bad idea too. I'd get it checked out at a reputable shop.
 

·
Administrator
Joined
·
2,904 Posts
Another 2010 thread.
 

·
Registered
Joined
·
12,831 Posts
Seems we have nothing to talk about anymore. What with resurrected threads and all.
Anyone do anything to their Indian ???
 

·
Registered
Joined
·
3,320 Posts
:doh:
 
1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top