VOG Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hey all,
I am new to the VOG and a new Vision owner. Just picked up an 08' from Arlen Ness. It has the twin sucker intake, Big Honker exhaust and a Big Shot tuner.
he problem is that it stalls sometimes after a long run. It does not do it when going stoplight to stoplight but if I go for a few miles at a steady throttle, it will die when I pull in the clutch to downshift.
I will be taking it in to Arlen Ness next week but thought I would see if there were any answers here from people who may have had the same issue.
Thanks in advance.
Jeff.
 

·
Registered
Joined
·
6,128 Posts

Jeff,
First off, welcome to the VOG. It's a great place to talk bikes.....and everything else. As for your problem, I also have an '08 and have never heard of this type of issue ever before. I can only gues what the issue may be but I bet it is gonna be tied back to the pipes, tuner, and mapping in some way. This is definately a new one.
 

·
Registered
Joined
·
4,500 Posts

Welcome!! Could be the tuner is not properly tuned.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·

The tuner was my first thought also. I'ts supposed to be very easy to set up and does not need a computer or dyno. It has a plus and minus button and some led's but with no instructions for the tuner, I'm not sure what the led's are supposed to look like when tuned properly.
I will be heading into Arlen Ness next week and see what they can tell me.
Thanks for the opinions and Thanks for the welcome.
 

·
Premium Member
Joined
·
3,850 Posts
Hi Jeff and Welcome To The VOG.

The earlier 08 Visions had a stalling issue that was remedied by a recall that had something to do with the ignition switch.

Check with your Dealer to confirm that your bike received this recall.

When it happened to me, it would stall out when slowing down after a highway ride. It never stalled at speed, only when slowing down. A pull on the clutch lever and then pressing the starter would fire it back up. Once the bike had the recall, I never experienced it again.

Hope this helps.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
Thanks for all the help. I'm heading over to Arlen Ness this weekend. I talked to Kevin Ness on the phone and he had similar issues with his. I will also check with the service manager while there to see if my bike has had the recall completed. I will post when it gets fixed with what the issue was determined to be.

Thanks again,
Jeff
 

·
Registered
Joined
·
189 Posts

Welcome to the family. I have an 08 but have not had or even seen it posted.
Do keep us informed.
 

·
Registered
Joined
·
531 Posts
I don't know about the Big Shot tuner, but with the Loyds, if it isn't set up correctly the samething can occur. It is an easy fix, minor adjustments with the tuner. See if Ness can give you a copy of the directions and you can learn how toadjustit yourself.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #10 ·
Willy,

Thanks, that's exactly my plan. Headed over to Ness tomorrow or monday and will get the instructions for the tuner and also talk to one of their tech guys on tuning it.
 

·
Registered
Joined
·
531 Posts

It is a common occurrence with the 08s. Mine does it every now and then. It usually happens when I pull in the clutch to downshift, it always starts right back up but it sure is annoying.

The tuner can probably take care of it, I have Lloyds tuner on mine and it definitely made an improvement and more than likely would cure it if I played with it some more.

Ness will take care of you.
Let us know how it goes.
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top