VOG Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
In May, I finally upgraded from a 39 year old Honda to a 9 year old Vision that up to now has been a dream ride. last weekend I went to start it and the battery was showing almost nothing. I put it on a charger overnight to no avail. Something else weird is that when I removed the key the screen on the radio blinked. I'm a truck driver and didn't have time to deal with it any further until today I decided to try to jump start it and now the battery shows normal voltage, but it still won't start, and the radio blinks when I remove the key. Any Ideas?
 

·
Super Moderator
Joined
·
26,093 Posts
It only started to show normal after the jump attempt?

Does it try to crank over?
 

·
Registered
Joined
·
2,497 Posts
Before digging too deep get the battery load tested, then you can eliminate that. Check fuses/relays and clean and tighten all battery connections, the 40 amp breaker can be bought at NAPA.
 

·
Registered
Joined
·
6,335 Posts
Try jumping it without the battery connected. If the battery is the short it can still show 12 volts but the bike won't do much of anything. Even jumping it won't help if it's shorted.
 

·
Super Moderator
Joined
·
26,093 Posts
I didn't ask but if you used a trickle charger when the battery was drained that's not the best. An actual battery charger should be used.

If the breaker test fine I'd get a new battery. I had to replace mine in my 13 this year.
 
  • Like
Reactions: mister-g
1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top