VOG Forum banner
1 - 20 of 21 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
So I have been having problems with my bike for a good time now. It all started last winter when it started to get cold down here in tx. I ride year round and once it got cold my bike would start for nothing. It would literally take me about 30 mins of cranking while it was on a battery charger to get it running. I tested the fuel pressure and nothing. So I ripped it apart and put new fuel pump,regulator, and filters. I also went ahead and cleaned the throttle bodies, air filter, and put new plugs and fresh oil in. Bike ran like a bat out of hell. Now recently I have been having problems with the bike running rough and big exhaust backfires when decelerating. Especially at higher rpms and dropping gears. So today I got out and did some testing. Plugs are good. No intake leaks. No exhaust leaks. Checked the fuel pressure and bam a whole 32 psi and then pressure drops to 0 psi as soon as the pump stops. So my question is, do y'all think I have an injector problem? Ex. Injector stuck open causing pressure to drop instantly and causing the bike to run to lean or rich and causing the rough running and backfire??? Y'all let me know I'm out of ideas. Oh and for upgrades is has k&n filter, Arlen Ness swept cut exhaust and has been dyno tuned. All performance upgrades where done around 500-1000 miles. Bike has 18,500 Now. Any help would be appreciated. Thanks.
 

·
Registered
Joined
·
23,463 Posts
That bike is 11 years old. Regardless of mileage, rubber parts don't last that long. All the fuel lines, the throttle body adaptor (intake manifold), and cap-offs on the side of the throttle body are suspect. You don't want intake leaks. You should replace the fuel filters too.

Black Font Line Rectangle Screenshot


Product Rectangle Font Slope Parallel


The little cap-offs on the throttle body are probably rotted off, so that's the easy fix... the rest needs to be done to, but the caps are probably the biggest issue.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #3 ·
Thanks for the feedback. I'll have to rip it apart and chech the cap offs. The fuel pump, pressure regulator and filters are brand new. And what about the pressure dropping off when I tested it with a gauge? It would only pump it to about 32 psi then drop to 0 once the pump stops.
 

·
Registered
Joined
·
23,463 Posts
Thanks for the feedback. I'll have to rip it apart and chech the cap offs. The fuel pump, pressure regulator and filters are brand new. And what about the pressure dropping off when I tested it with a gauge? It would only pump it to about 32 psi then drop to 0 once the pump stops.
The fuel pump could have a leaking connection/seal someplace on the input or output side, losing pressure or prime.
 

·
Registered
Joined
·
6,846 Posts
I have an 07 and I had to replace the parts H_C is talking about last year on mine. Not only those, but they found that the o-rings to the fuel injectors had basically disintegrated as well. That alone could easily explain the fuel pressure drop off you're seeing.
 

·
Registered
Joined
·
1,716 Posts
32psi is really low ... should be 50 .. it is possible that the pump is leaking. We had an 05 vegas in recently with similar problems. Would start up, but ran like **** and would only get to 32 psi .. we replaced with a brand new pump assembly, filters, etc and it solved all the issues.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #10 ·
32psi is really low ... should be 50 .. it is possible that the pump is leaking. We had an 05 vegas in recently with similar problems. Would start up, but ran like **** and would only get to 32 psi .. we replaced with a brand new pump assembly, filters, etc and it solved all the issues.
So if the pump is leaking and pressure is low will that cause it to run lean and backfire?
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #12 ·
I'm tryna ball on a budget here so if I can fix it myself then it would help me a lot. I think that the rubber seal on the outlet of the pump that goes into the pressure regulator isn't sealing so I'll try to fix that and test it.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #14 ·

·
Registered
Joined
·
17 Posts
Discussion Starter · #15 ·
So I got the tank off and the pump back off and I'm gonna replace the rubber seal on the outlet of the pump. And I also found that the vacuum cap offs on the throttle body were both cracked. I'll get both problems fixed and give y'all an update. Thanks for all the help I didn't want to send this bike to the shop and pay out the a**. I'm a lil mechanically inclined so I'll try my best at it. It's just a learning curve working on these victorys but I find that they are pretty easy to get around.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #16 ·
So I got new cap off for the throttle body. And i replaced the rubber seal on the outlet of the pump. Put the tank all back together and put gas in it. I cycled the pump on and off 3 or 4 times to prime and get all the air out. Each time pressure got higher and higher. Then on the last try it got to about 45psi and began to have a loud high pitch squeal. Anybody have any ideas?
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #18 ·
Well the bike if fixed. The reason for the loud squeal from the pump was because the pressure regulator was leaking. I put a larger o ring on it and no more leaks. Pressure was good and the bike is running like a champ. No more hesitation or backfire. Thank y'all for all the help.
 

·
Registered
Joined
·
7 Posts
That bike is 11 years old. Regardless of mileage, rubber parts don't last that long. All the fuel lines, the throttle body adaptor (intake manifold), and cap-offs on the side of the throttle body are suspect. You don't want intake leaks. You should replace the fuel filters too.

View attachment 452913

View attachment 452921

The little cap-offs on the throttle body are probably rotted off, so that's the easy fix... the rest needs to be done to, but the caps are probably the biggest issue.
This will happen this week! Thanks again.
 
1 - 20 of 21 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top